#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\n#*]+\s*)"
Local $sString = "<!-- Comment 1 -->" & @CRLF & _
"<!-- Comment 2 multiline" & @CRLF & _
"Comment 2a" & @CRLF & _
"Comment 2b-->" & @CRLF & _
"<noinclude>" & @CRLF & _
"{{draft}}" & @CRLF & _
"[[Category:List by frequency]]" & @CRLF & _
"</noinclude>" & @CRLF & _
"== Inline ==" & @CRLF & _
"one # twor !! #two and half# L1phrase → L2 definition" & @CRLF & _
"" & @CRLF & _
"== List ==" & @CRLF & _
"# One" & @CRLF & _
"# Two !!" & @CRLF & _
"# Two and half" & @CRLF & _
"# L1phrase → L2 definition" & @CRLF & _
"# L1 item → L2 definition [pos:adjective, ipa: /vɜːt/]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"== Hidden pseudo JSON" & @CRLF & _
"# 他 → { item:他, simplified:他, pinyin:tā, IPA:tʰa˥˥, eng:he }," & @CRLF & _
"# 我們 → { item:我們, simplified:我们, pinyin:wǒmen, IPA:uɔ˨˩mən, eng:we}," & @CRLF & _
"" & @CRLF & _
"== Poems ==" & @CRLF & _
"" & @CRLF & _
" *** " & @CRLF & _
"" & @CRLF & _
"INVICTUS (SENTENCES)" & @CRLF & _
"" & @CRLF & _
"Out of the night that covers me" & @CRLF & _
"Black as the pit from pole to pole," & @CRLF & _
"I thank whatever gods may be" & @CRLF & _
"For my unconquerable soul." & @CRLF & _
"" & @CRLF & _
"In the fell clutch of circumstance," & @CRLF & _
"I have not winced nor cried aloud." & @CRLF & _
"Under the bludgeonings of chance" & @CRLF & _
"My head is bloody, but unbowed." & @CRLF & _
"" & @CRLF & _
"Beyond this place of wrath and tears" & @CRLF & _
"Looms but the Horror of the shade," & @CRLF & _
"And yet the menace of the years" & @CRLF & _
"Finds, and shall find, me unafraid." & @CRLF & _
"" & @CRLF & _
"It matters not how strait the gate," & @CRLF & _
"How charged with punishments the scroll," & @CRLF & _
"I am the master of my fate" & @CRLF & _
"I am the captain of my soul." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"INVICTUS (POEM MODE)" & @CRLF & _
"" & @CRLF & _
"Out of the night that covers me" & @CRLF & _
"Black as the pit from pole to pole," & @CRLF & _
"I thank whatever gods may be" & @CRLF & _
"For my unconquerable soul." & @CRLF & _
"" & @CRLF & _
"In the fell clutch of circumstance," & @CRLF & _
"I have not winced nor cried aloud." & @CRLF & _
"Under the bludgeonings of chance" & @CRLF & _
"My head is bloody, but unbowed." & @CRLF & _
"" & @CRLF & _
"Beyond this place of wrath and tears" & @CRLF & _
"Looms but the Horror of the shade," & @CRLF & _
"And yet the menace of the years" & @CRLF & _
"Finds, and shall find, me unafraid." & @CRLF & _
"" & @CRLF & _
"It matters not how strait the gate," & @CRLF & _
"How charged with punishments the scroll," & @CRLF & _
"I am the master of my fate" & @CRLF & _
"I am the captain of my soul." & @CRLF & _
""
Local $sSubst = "\n# "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)