import re
regex = re.compile(r"([\n#*]+\s*)", flags=re.MULTILINE)
test_str = ("<!-- Comment 1 -->\n"
"<!-- Comment 2 multiline\n"
"Comment 2a\n"
"Comment 2b-->\n"
"<noinclude>\n"
"{{draft}}\n"
"[[Category:List by frequency]]\n"
"</noinclude>\n"
"== Inline ==\n"
"one # twor !! #two and half# L1phrase → L2 definition\n\n"
"== List ==\n"
"# One\n"
"# Two !!\n"
"# Two and half\n"
"# L1phrase → L2 definition\n"
"# L1 item → L2 definition [pos:adjective, ipa: /vɜːt/]\n\n\n\n"
"== Hidden pseudo JSON\n"
"# 他 → { item:他, simplified:他, pinyin:tā, IPA:tʰa˥˥, eng:he },\n"
"# 我們 → { item:我們, simplified:我们, pinyin:wǒmen, IPA:uɔ˨˩mən, eng:we},\n\n"
"== Poems ==\n\n"
" *** \n\n"
"INVICTUS (SENTENCES)\n\n"
"Out of the night that covers me\n"
"Black as the pit from pole to pole,\n"
"I thank whatever gods may be\n"
"For my unconquerable soul.\n\n"
"In the fell clutch of circumstance,\n"
"I have not winced nor cried aloud.\n"
"Under the bludgeonings of chance\n"
"My head is bloody, but unbowed.\n\n"
"Beyond this place of wrath and tears\n"
"Looms but the Horror of the shade,\n"
"And yet the menace of the years\n"
"Finds, and shall find, me unafraid.\n\n"
"It matters not how strait the gate,\n"
"How charged with punishments the scroll,\n"
"I am the master of my fate\n"
"I am the captain of my soul.\n\n\n\n\n"
"INVICTUS (POEM MODE)\n\n"
"Out of the night that covers me\n"
"Black as the pit from pole to pole,\n"
"I thank whatever gods may be\n"
"For my unconquerable soul.\n\n"
"In the fell clutch of circumstance,\n"
"I have not winced nor cried aloud.\n"
"Under the bludgeonings of chance\n"
"My head is bloody, but unbowed.\n\n"
"Beyond this place of wrath and tears\n"
"Looms but the Horror of the shade,\n"
"And yet the menace of the years\n"
"Finds, and shall find, me unafraid.\n\n"
"It matters not how strait the gate,\n"
"How charged with punishments the scroll,\n"
"I am the master of my fate\n"
"I am the captain of my soul.\n")
subst = "\\n# "
result = regex.sub(subst, test_str)
if result:
print(result)