package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)tel:(?<phnum>[0-9+-]+)`)
var str = `TEL;VALUE=uri;PREF=1;TYPE=\"voice,home\":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\"voice,home\":tel:+1-555-555-5555;ext=5555
TEL;VALUE=uri;PREF=1;TYPE=\"voice,home\":tel:+1-555-555-5555;ext=5555;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}