import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "tel:(?<phnum>[0-9+-]+)";
final String string = "TEL;VALUE=uri;PREF=1;TYPE=\\\"voice,home\\\":tel:+1-555-555-5555;ext=5555\n\n"
+ "TEL;VALUE=uri;PREF=1;TYPE=\\\"voice,home\\\":tel:+1-555-555-5555;ext=5555\n\n"
+ "TEL;VALUE=uri;PREF=1;TYPE=\\\"voice,home\\\":tel:+1-555-555-5555;ext=5555;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}