// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)0?(?:[1-9]|1[0-2])\/0?(?:[1-9]|12[0-9]|3[01])\/1\d{3}").unwrap();
let string = "12/10/2021
1/1/1990
01/08/1937
15/36/1718
3/33/1999
1/2/2000
12/9/1906
13/31/1999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}