package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]|[1-9][0-9]|1([0-1][0-9]|20))$`)
var str = `120
-1
1
25
99
100
119`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}