$re = '/^([0-9]|[1-9][0-9]|1([0-1][0-9]|20))$/m';
$str = '120
-1
1
25
99
100
119';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);