using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Hello ([^,]+)";
string input = @"Hello Frederic Abin,
hello Anna Banana,
HELLO Omar Urael,
Hello, no match here
I am a banana";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}