$re = '/Hello ([^,]+)/i';
$str = 'Hello Frederic Abin,
hello Anna Banana,
HELLO Omar Urael,
Hello, no match here
I am a banana';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);