#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\w+$"
Local $sString = "abc" & @CRLF & _
"foo"
Local $sSubst = "#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)