package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+$`)
var str = `abc
foo`
var substitution = "#"
fmt.Println(re.ReplaceAllString(str, substitution))
}