#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)(?=^((?:Item 1|Item 1a|Item 1b).*?^(?:Item 2|Item 2a|Item 2b)))"
Local $sString = "Item 1 ...." & @CRLF & _
"Item 2 ...." & @CRLF & _
"Item 1 ...." & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"Item 2 ...." & @CRLF & _
"Item 1 ...." & @CRLF & _
"Item 2" & @CRLF & _
"Item 1a ...." & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"...." & @CRLF & _
"Item 2b ...."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")