import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)(?=^((?:Item 1|Item 1a|Item 1b).*?^(?:Item 2|Item 2a|Item 2b)))";
final String string = "Item 1 ....\n"
+ "Item 2 ....\n"
+ "Item 1 ....\n"
+ "....\n"
+ "....\n"
+ "Item 2 ....\n"
+ "Item 1 ....\n"
+ "Item 2\n"
+ "Item 1a ....\n"
+ "....\n"
+ "....\n"
+ "....\n"
+ "....\n"
+ "Item 2b ....";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}