package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(A (A|B(*ACCEPT)|C)+ D)(E)`)
var str = `ABCDE
ACDE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}