$re = '/(A (A|B(*ACCEPT)|C)+ D)(E)/mx';
$str = 'ABCDE
ACDE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);