using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"startword([^e]*(?:e(?!ndword)[^e]*)*)endword";
string input = @"startword text
here
...
endword";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}