re = /startword([^e]*(?:e(?!ndword)[^e]*)*)endword/m
str = 'startword text
here
...
endword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end