// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([sS][gG][1|4]|[aA][lL][6-7|10|2-3]|[wW][dD][23|25|7|4]|[hH][pP][1|3-4]|[lL][uU]1)\d?\b").unwrap();
let string = "SG1
SG4
AL2
AL6
AL7
AL10
WD4
WD7
WD23
WD25
HP1
HP3
HP4
LU1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}