using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:[^\d\r\n]*\d){6})[a-z0-9]{5,15}$";
string input = @"helloworld
123helloworld56
1h2e3l4l5oworld
12345
123456
123hello4567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}