$re = '/^(?!(?:[^\d\r\n]*\d){6})[a-z0-9]{5,15}$/m';
$str = 'helloworld
123helloworld56
1h2e3l4l5oworld
12345
123456
123hello4567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);