#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*\S[MG]O\b)[a-zA-Z0-9,()]+(?: [a-zA-Z0-9,()]+)*$"
Local $sString = "aaaa test" & @CRLF & _
"test MO test" & @CRLF & _
"test this is GO" & @CRLF & _
"GO" & @CRLF & _
"MO" & @CRLF & _
"test AMO test" & @CRLF & _
"test AGO test" & @CRLF & _
"a" & @CRLF & _
"" & @CRLF & _
"It is 40 GO" & @CRLF & _
"" & @CRLF & _
"It is 40GO" & @CRLF & _
"" & @CRLF & _
"It is 40 GO"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")