re = /^(?!.*\S[MG]O\b)[a-zA-Z0-9,()]+(?: [a-zA-Z0-9,()]+)*$/mi
str = 'aaaa test
test MO test
test this is GO
GO
MO
test AMO test
test AGO test
a
It is 40 GO
It is 40GO
It is 40 GO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end