# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d[^\W_]{5,})"
test_str = ("22CI003294 PARCEL 32 \n"
"22CI400040 NORFOLK ESTATES \n"
"12CI400952 & 13CI403261\n"
"22CI400628 GARDEN ACRES\n"
"9CI00208 FERNHAVEN SEC\n"
"22CI400675 CECIL AVE SUB\n"
"22CI400721 124.69' SS")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.