import Foundation
let pattern = #"^(\d[^\W_]{5,})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
22CI003294 PARCEL 32
22CI400040 NORFOLK ESTATES
12CI400952 & 13CI403261
22CI400628 GARDEN ACRES
9CI00208 FERNHAVEN SEC
22CI400675 CECIL AVE SUB
22CI400721 124.69' SS
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)