use strict;
my $str = '[2024-01-31_07:58:28] INFO : REQUEST: User:abc CreateUser POST: name: AB_Test_Max;email: xyz@gmail.com;password: abc12345679;cpassword: abc12345679;role: User;
[2024-01-30_14:05:42] INFO : REQUEST: User:xyz CreateUser POST: name: Math_Lab;email: abc@yahoo.com;password: xyzab54;cpassword: xyzab54;role: Admin;';
my $regex = qr/password: ([^;]+);cpassword: ([^;]+);/mp;
my $subst = '/password: (####);cpassword: (####);';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";