// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)password: ([^;]+);cpassword: ([^;]+);").unwrap();
let string = "[2024-01-31_07:58:28] INFO : REQUEST: User:abc CreateUser POST: name: AB_Test_Max;email: xyz@gmail.com;password: abc12345679;cpassword: abc12345679;role: User;
[2024-01-30_14:05:42] INFO : REQUEST: User:xyz CreateUser POST: name: Math_Lab;email: abc@yahoo.com;password: xyzab54;cpassword: xyzab54;role: Admin;";
let substitution = "/password: (####);cpassword: (####);";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}