import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^<\\d{4}> )|(\\\\(\\w+)?\\{.*?\\})";
final String string = "// Resources for SEEN0001.TXT\n\n"
+ "#character '美佐枝'\n"
+ "#character '春原'\n"
+ "#character 'ボタン'\n\n"
+ "<0000> \\{美佐枝}You little goblin...\n"
+ "<0001> Unable to contain her fury, Misae grabs both of Sunohara's legs...\n"
+ "<0002> \\{春原}Heh?\n"
+ "<0003> ...and proceeds to use her killing move, The Giant Swing.\n"
+ "<0004> \\{美佐枝}Uryaaaaaaaaaaaaaaaaaaa!\n"
+ "<0005> \\{春原}Uwaaaaaaaaaaaaaah!\n"
+ "<0006> \\{ボタン}Puhiiii.\n"
+ "<0007> \\{春原}Uwaaaaaaaaaaah!\n"
+ "<0008> \\{春原}Uwaaaaaaaaaaah!\n"
+ "<0009> \\{春原}Uwaaaaaaaaaaah!\n"
+ "<0010> \\{春原}Geeh!\n"
+ "<0171> \\size{intA[1001]}*BOOM*\\size{}\\shake{4}\n"
+ "<0145> \\size{intA[1001]}Dammit! Stupid rugby players!!\\size{}\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}