package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^v?[0-9].[0-9].[0-9]-dev[0-9]$`)
var str = `v1.2.3-dev1
1.2.3-dev1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}