$re = '`^v?[0-9].[0-9].[0-9]-dev[0-9]$`m';
$str = 'v1.2.3-dev1
1.2.3-dev1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);