$re = '/(?<=#)\d++(?!\.)/';
$str = 'my car number is #8746253 which is actually cool
earth is #8746253.Kms away, which is very far';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);