re = /(?<=#)\d++(?!\.)/
str = 'my car number is #8746253 which is actually cool
earth is #8746253.Kms away, which is very far'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end