re = /\/application(?!(\/something\/unwanted\/else))/m
str = '/application/something/else
/application/something/unwanted/else'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end