$re = '/\b(\w)(?:.*?\b\1){3}/m';
$str = 'cat color coral chat
cat take boom candle creepy drum cheek
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);