re = /\b(\w)(?:.*?\b\1){3}/m
str = 'cat color coral chat
cat take boom candle creepy drum cheek
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end