package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\\$`)
var str = `sd sewq wee r r ttttt $300 rrtrt utu iwiwi \$500 kjgf ihj \$215 ghi`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}