import re
regex = re.compile(r"^(\+\d{3}\s?)?\(?\d{3}\)?[\s-]*\d{2}[\s-]*\d{2}[\s-]*\d{2}$", flags=re.MULTILINE)
test_str = ("+224 664 36 07 29\n"
"+224(664) 36 07 29\n"
"(664)36 07 29\n"
"+224664360729\n"
"664 36 07 29\n"
"664-36-07-29\n\n"
"66436\n"
"(664)\n"
"\\(?\\d{3}\\)?[\\s.-]\\d{3}[\\s.-]\\d{4}$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")