use strict;
my $str = '+0.0
0.0
-00.00
-000.000
10
5
-7.9
-10.88765444
-1234566.86654432
12355.79795763649
10..2
++1231
--99.0
--444..555
.99
7.
888888...4
984hb7822
';
my $regex = qr/^[+-]?\d+(?:\.\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}