import re
regex = re.compile(r"^[+-]?\d+(?:\.\d+)?$", flags=re.MULTILINE)
test_str = ("+0.0\n"
"0.0\n"
"-00.00\n"
"-000.000\n"
"10\n"
"5\n"
"-7.9\n"
"-10.88765444\n"
"-1234566.86654432\n"
"12355.79795763649\n\n"
"10..2\n"
"++1231\n"
"--99.0\n"
"--444..555\n"
".99\n"
"7.\n"
"888888...4\n"
"984hb7822\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")