using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^/\s]+/)+[^/\s]+$";
string input = @"data/files.xml
share/home.html
demo45/photos
demo45/photos/holiday/2015/bahamas";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}