package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^/\s]+/)+[^/\s]+$`)
var str = `data/files.xml
share/home.html
demo45/photos
demo45/photos/holiday/2015/bahamas`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}