re = /([^:\s]+)*\s*:\s*([^;]+);/
str = 'color: red;
bg: wat;
how : \'bout-that\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end