import re
regex = re.compile(r"(?s)(?|([0-9]{1,2}h)[ ]*([0-9]{1,2}min)|([0-9]{1,2}h)()|()([0-9]{1,2}min)):\s*((?:.(?!(\dh\s\d{1,2}min|\dh|\d{1,2}min)))+)")
test_str = ("1h 30min: Title \n"
"- Description Line 1\n"
"3h: SECOND TITLE\n"
"- Description Line 1\n"
"- Description Line 2\n"
"- Description Line 3\n\n\n"
"1h 14min: Title \n"
"- another Great one 42min: Title - Great Movie\n"
"- Description Line 2\n"
"- Description Line 3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")