package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\*[a-zA-Z\s]*\*)`)
var str = `Create personalised *tasty treats* and branded *promotional products* *tasty treats*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}