re = /(\*[a-zA-Z\s]*\*)/m
str = 'Create personalised *tasty treats* and branded *promotional products* *tasty treats*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end