# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\+?1?\W*([2-9]{3})\W*([2-9]{3})[\s.-]*(\d{4})\s*$"
test_str = ("(223) 456-7890\n"
"223.456.7890\n"
"223 456 7890 \n"
"+1 (223) 456-7890\n"
"+1 (223) 456-7890\n"
"123456789\n"
"22234567890\n"
"12234567890\n"
"+1 (223) 456-7890\n"
"321234567890\n"
"123-abc-7890\n"
"123-@:!-7890\n"
"(023) 456-7890\n"
"(123) 456-7890\n"
"(223) 056-7890\n"
"(223) 156-7890\n"
"1 (023) 456-7890\n"
"1 (123) 456-7890\n"
"1 (223) 056-7890\n"
"1 (223) 056-7890")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.