import Foundation
let pattern = #"^\+?1?\W*([2-9]{3})\W*([2-9]{3})[\s.-]*(\d{4})\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(223) 456-7890
223.456.7890
223 456 7890
+1 (223) 456-7890
+1 (223) 456-7890
123456789
22234567890
12234567890
+1 (223) 456-7890
321234567890
123-abc-7890
123-@:!-7890
(023) 456-7890
(123) 456-7890
(223) 056-7890
(223) 156-7890
1 (023) 456-7890
1 (123) 456-7890
1 (223) 056-7890
1 (223) 056-7890
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)