import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:https?|ftp):\\/\\/)(?:\\S+(?::\\S*)?@)?(?:(?!10(?:\\.\\d{1,3}){3})(?!127(?:\\.\\d{1,3}){3})(?!169\\.254(?:\\.\\d{1,3}){2})(?!192\\.168(?:\\.\\d{1,3}){2})(?!172\\.(?:1[6-9]|2\\d|3[0-1])(?:\\.\\d{1,3}){2})(?:[1-9]\\d?|1\\d\\d|2[01]\\d|22[0-3])(?:\\.(?:1?\\d{1,2}|2[0-4]\\d|25[0-5])){2}(?:\\.(?:[1-9]\\d?|1\\d\\d|2[0-4]\\d|25[0-4]))|(?:(?:[a-z\\x{00a1}-\\x{ffff}0-9]+-?)*[a-z\\x{00a1}-\\x{ffff}0-9]+)(?:\\.(?:[a-z\\x{00a1}-\\x{ffff}0-9]+-?)*[a-z\\x{00a1}-\\x{ffff}0-9]+)*(?:\\.(?:[a-z\\x{00a1}-\\x{ffff}]{2,})))(?::\\d{2,5})?(?:\\/?)(?:(?:\\?(?:(?!&|\\?)(?:\\S))+=(?:(?!&|\\?)(?:\\S))+)(?:&(?:(?!&|\\?)(?:\\S))+=(?:(?!&|\\?)(?:\\S))+)*)?$";
final String string = "google.com\n\n"
+ "http://google.com\n"
+ "https://google.com\n\n"
+ "https://www.google.com\n"
+ "https://www.google.com/\n\n"
+ "https://google.com/?\n"
+ "https://google.com?\n"
+ "https://google.com?a\n"
+ "https://google.com?a=\n"
+ "https://google.com?a=b\n"
+ "https://google.com?a=b?\n"
+ "https://google.com?a=b&\n"
+ "https://google.com?a=b&c\n"
+ "https://google.com?a=b&c=\n"
+ "https://google.com?a=b&c=d\n"
+ "https://google.com?a=b&c=d?\n"
+ "https://google.com?a=b&c=d&\n"
+ "https://google.com?a=b&c=d&e=\n"
+ "https://google.com?a=b&c=d&e=f\n\n"
+ "https://google.com?hello=world&yes=123&onw={123}\n"
+ "https://google.com/?hello=world&yes=123&onw={123}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}