re = /^(?:(?:https?|ftp):\/\/)(?:\S+(?::\S*)?@)?(?:(?!10(?:\.\d{1,3}){3})(?!127(?:\.\d{1,3}){3})(?!169\.254(?:\.\d{1,3}){2})(?!192\.168(?:\.\d{1,3}){2})(?!172\.(?:1[6-9]|2\d|3[0-1])(?:\.\d{1,3}){2})(?:[1-9]\d?|1\d\d|2[01]\d|22[0-3])(?:\.(?:1?\d{1,2}|2[0-4]\d|25[0-5])){2}(?:\.(?:[1-9]\d?|1\d\d|2[0-4]\d|25[0-4]))|(?:(?:[a-z\x{00a1}-\x{ffff}0-9]+-?)*[a-z\x{00a1}-\x{ffff}0-9]+)(?:\.(?:[a-z\x{00a1}-\x{ffff}0-9]+-?)*[a-z\x{00a1}-\x{ffff}0-9]+)*(?:\.(?:[a-z\x{00a1}-\x{ffff}]{2,})))(?::\d{2,5})?(?:\/?)(?:(?:\?(?:(?!&|\?)(?:\S))+=(?:(?!&|\?)(?:\S))+)(?:&(?:(?!&|\?)(?:\S))+=(?:(?!&|\?)(?:\S))+)*)?$/im
str = 'google.com
http://google.com
https://google.com
https://www.google.com
https://www.google.com/
https://google.com/?
https://google.com?
https://google.com?a
https://google.com?a=
https://google.com?a=b
https://google.com?a=b?
https://google.com?a=b&
https://google.com?a=b&c
https://google.com?a=b&c=
https://google.com?a=b&c=d
https://google.com?a=b&c=d?
https://google.com?a=b&c=d&
https://google.com?a=b&c=d&e=
https://google.com?a=b&c=d&e=f
https://google.com?hello=world&yes=123&onw={123}
https://google.com/?hello=world&yes=123&onw={123}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end