import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*[0-9]* *([a-zA-Z]+[0-9]*)+( *\\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))*\\s*$";
final String string = "A + B\n"
+ "2H2 + O2\n"
+ "2H2O\n"
+ "C + O2\n"
+ "2H2O \n"
+ " 2H2O\n"
+ " 2H2O ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}