import re
regex = re.compile(r"^\s*[0-9]* *([a-zA-Z]+[0-9]*)+( *\+ *[0-9]*([a-zA-Z]{1,2}[0-9]*))*\s*$", flags=re.MULTILINE)
test_str = ("A + B\n"
"2H2 + O2\n"
"2H2O\n"
"C + O2\n"
"2H2O \n"
" 2H2O\n"
" 2H2O ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)